Requirements and licensing

Requirements

CoBaLT consists of an application and a database. It is considered good practise to install the two components on separate servers. The first one (which will house the PHP/Perl code) is the application server, and the second one will act as the (MySql) database server.

As a reference for hardware requirements, here are the specifications of the servers on which CoBaLT is developed and maintained at the moment, with good performance as a result:

Application server:

  • CPU : Intel Xeon e5 2,3 GHz FIO
  • Mem : 4Gb
  • Storage : 8Gb iscsi storage
  • Application-storage : 30 MB
  • OS : Debian squeeze
  • Software : Apache 2.2.16 / PHP 5.3.3 / Perl v5.10.1 (*) built for x86_64-linux-gnu-thread-multi

Database server:

  • OS : Redhat 5
  • Software MySql : ver 14.12
  • CPU : Intel Xeon e5 2,3 GHz FIO
  • Mem : 4Gb
  • Storage : 60Gb
  • Appstorage : 700MB

Licensing

The tool is produced at the Instituut voor Nederlandse Lexicologie (INL) in Leiden, Netherlands.
It is licensed under the Apache License, Version 2.0 (http://www.apache.org/licenses/LICENSE-2.0).